Changes to files aren't propagating?


#1

Hello all,

We’re encountering a rather strange issue with cloud9.

We have a file called templates/card.html. We modified this so that there was a noticeable and obvious change. We saved the file, hard refreshed, and the changes didn’t propagate to the website we’re developing.

We do have some esoteric page loading logic but it is working in other instances, just not in a couple. The implementation is the same.

Renaming the file and ensuring the logic loads that file instead works fine, but no other changes appear to fix it.


#2

I noticed something similar yesterday with my java changes not being reflected when I ran the code. I did a hard refresh too and same thing. I had to close the terminal that was running the java before my changes were realized. It has not happened again. I figure that a hard refresh is really only for the client side issue and it was a workspace side instance of things not updating properly. So the hard refresh of the page meant me just reloading my page that displayed the workspace. closing the terminal in the workspace and hitting the run button again actually picked up the changes that I made.


#3

Yeah, we concluded that it must be something server-side, so we weren’t sure what the right fix would be. We closed it down without making any further changes and it appears to be fixed now - so restarting the terminal process seems to be the fix.

ETA: Actually, having programmed more today, we’re noticing just closing the terminal doesn’t fix it. :frowning:


#4

Bumping this topic. We’re finding it extremely difficult to test our product since Cloud9 is our primary development platform.


#5

I have the same problem. Everything was working fine just yesterday but today I cannot see any changes I make to my files. Is there a problem on the server? If anyone has any solution please share. It’s impossible to do anything :<

EDIT
It seems it works now. Still don’t know what the problem was, as I didn’t even restart the workspace now.


#6

I see this occasionally and am seeing this today. I have to close everything down, and restart the environment. note: I’m using chrome as a browser and do an empty cache and hard reload, so it does seem to be the server.


#7

Same here… I can’t use C9 due this, I’ve spent lots of minutes to figure it why my changes wasn’t been there


#8

I often, even usually, have this problem. It makes it very difficult to debug.


#9

Same as:

This is obviously a big problem for any web developer, what I thought was C9’s primary customers. How come no c9 employee has addressed this very significant impediment?