Can't type anything into terminal?

workspace
terminal

#1

I’m unable to type anything in to my terminal and it’s simply blank whenever I open it up.

Things I’ve tried:

  • restarting my workspace mutltiple times
  • restarting my browser (chrome)
  • logging off and logging back on
  • closing the terminal completely and opening a new one from scratch

No matter what I try, I’m just left with a blank terminal that has a cursor but doesn’t seam to respond to any input.


#2

This happen to me from time to time and when I’m patient I just kinda forget about it and eventually comes back, seems like sometime just takes FOREVER to load the terminal, but when I’m not su patient opening a new session one or more times usually fixes things right up.


#3

@aondra good details, thanks for that. Is this an SSH workspace or a hosted workspace? Is this happening in any of your other workspaces? Do you see any errors in the browser console?


#4

@bradydowling
This is a hosted workspace. I’m on a free account so I can’t actually create any other workspaces at the moment.

I see a bunch of errors in the browser window. A few of them make it seem like something screwed up some of the pieces that C9 needs to work. For example, Here’s one of the error messages:

“ENOENT: no such file or directory, open ‘/home/ubuntu/.c9/installed’”

Is my best bet at this point to delete my workspace and restart? Is there any way to reset the workspace itself but still keep my local files? Can I perhaps get the IP so I can SSH to it?


#5

There’s no way to SSH into workspaces but you should be able to download the files by right-clicking your workspace folder on the left side. Let me know if that works and then we’ll go from there. Oh and you should be able to create other public workspaces so give that a shot too.


#6

@bradydowling Thanks for all your help.

I downloaded my stuff as a backup, and I’m pretty sure I already had everything committed anyways (yay version control).

Looking through the browser console more makes me think it may have had something to do with some custom tools I had installed. I like using Terminator and Tmux when I develop, and I see errors in the browser console relating to tmux, so I’m wondering if that could have been causing some of the problems.

Here’s an example of what I mean from the browser console:
Uncaught TypeError: Cannot read property ‘message’ of null(…)
workspace-cpp.js:23111 KILLING SESSION: undefinedkill @ workspace-cpp.js:23111
workspace-cpp.js:23113 Killed tmux session: undefinedkill @ workspace-cpp.js:23113
workspace-cpp.js:23094 Disregard terminal: undefined


#7

Sounds very likely to me. It’s tough to tell how you installed tmux and what you did there but Cloud9 workspaces use tmux to provide you terminal access so if you changed that installation at all then that’s probably causing the issues.

Don’t mess with tmux :wink: Or if you want to, do it in a throwaway workspace so you can test the limits without toying with your favorite workspace. Cloud9 is good for that!


#8

hahah yepppppp that would have done it then.

I have a “Dev Kit” that I pull from my own github that does not play nicely at all with previous installations of tmux, terminator, or vim :grin: I had no idea c9 used tmux, and didn’t even bother to look before pulling my devkit down.

Thanks again for all the help, and I’ll make sure to be more careful on my next workspace.


#9

ctrl + q
may help?
Saw from this post: https://stackoverflow.com/questions/22703714/cloud-9-c9-io-terminal-will-not-allow-me-to-enter-text
and one guy saw from this
https://unix.stackexchange.com/questions/12107/how-to-unfreeze-after-accidentally-pressing-ctrl-s-in-a-terminal/12108#12108


#10

The CTRL + q worked for me! I love you.