Can't sign up, server returned an error: Declined


#1

After filling all the fields and credit card verification, and after the captcha, when I click Create account I get the following message:

Something went wrong while creating your account
The server returned an error: Declined
I’m working on a MacBook Air, I’ve tried signing up from Chrome in Normal and Incognito mode, Safari, and an Ubuntu VM using Mozilla Firefox and I still can’t sign up. Any help would be greatly appreciated.


#2

Same thing. I don’t understand why. I’m from Spain.


#3

Hi,

Same problem here. Ansd the same for the guy of this link.https://community.c9.io/t/sign-up-decline

I am also spanish…


#4

And same problem for me :frowning:


#5

I’m Brazilian. I have a credit card national, not internacional. I can’t create my account.


#6

Same problem, I cannot create the account. I am from Venezuela.


#7

I tried to sign up from several OS Windows, Ubuntu, tried with different browsers, chrome, firefox and Internet Explorer, and I could not sign up on C9

I think you are missing a big part of your market

I dont understand why I cannot sign up. Many times the reCaptcha’s images did not appear, in order to select them… In Chrome with windows or Ubuntu happend. Please improve that step, that recaptcha have many errors.

In firefox with winXP, the captcha appears, but returned CVC or CCV declined error. Sorry, I dont have an international credit card to try-

Please, reconsider your sign up processs.


#8

I have a similar problem. When trying to sign in when giving my cc information there is a mandatory zipcode
form box that I cannot click on to fill in but I cannot go forward either.


#9

Hi everyone I had the same problem. Make sure you have checked the balance before you use the card for signup!. C9 will deduct and add some amount of money.


#10

Same problem, I cannot create the account. I am from Taiwan.


#11

@mutahhir Mine says AVS error. I am applying from Mainland China. Is there a solution to this or someone I can reach out to? Has anyone from the US had this problem, or is it just those applying from abroad?


#13

So many people with the same problem. I hope c9 managers could provide us with a solution.

I tried to sign up with firefox in CentOS and Win7 but neither succeed. At the first beginning, the captcha js even couldn’t be loaded.


#14

I have the same error message, with a Canadian credit card. Cloud 9 is loosing business and they don’t seem to care so much… I guess I will go to CodeAnywhere


#15

These issues are usually caused by card companies or banks rejecting the payment or verification and it is very difficult to troubleshoot on our end. Please reach out to your credit card company and see if there’s something they can do to ensure the credit card verification happens successfully.


#16

Hey,

I experienced the same declined issue on sign up. Based in UK, I entered two HSBC debit & credit cards with no luck. My Monzo card worked straight away. Tip to anyone else is to just try every card you own!


#17

Dear @bradydowling,

My error is: “Gateway rejected: avs” contains critical information.
So many potential users have this issue since 2016 and it is still not resolved.
It is easy to say it is a problem with our banks but it is not.
I use my card for various other sites as well for payment and for identification.
Sometimes it gives problems with postal code as my country (Ireland) does no have postal codes.
Usually this is easy to hack by using ‘Ireland’ or ‘00000’ or whatever.
In your application these are not accepted.
The question you need to ask is which code would not give an error so you can really help us.
You would have no idea how many people can’t make an account and do not report it. Embrace our reports and do something to help us instead.
Our banks can’t change our postal code system and certainly not your backend.
Looking forward for a real solution.

Any one else knows a similar/comparing app where I can do the same stuff?


#18

www.codeanywhere.com and www.codenvy.io have very easy sign up processes. No cc needed and signup with github etc. With the last you get 3G free instead of 1G.


#19

just sign up in aws https://aws.amazon.com/?nc2=h_lg doing the payment process and then again come again at the c9 page and then create your account. it worked for me after a long time i got rid of this thing. best of luck for everyone