Can't sign in to C9


#1

Trying to sign in to C9 from Finland. Signing in with the correct password does nothing, but in the console there are three error messages:
– A POST call to https://c9.io/auth/login 403 (Forbidden)
– A GET call to GET https://api.c9.io/user?access_token=xxx 401 (Unauthorized)
– Uncaught RangeError: Maximum call stack size exceeded (profile.js:862)

Using an incorrect password gives the “Incorrect password” message.


#2

It seems that all the attempted logins were kind of successful after all despite the errors, as once I tried to open the dashboard directly it opened a-ok showing all workspaces. However, once I try to open any workspaces they don’t open correctly but are stuck in a loop with error messages in console:

LOGIN: API /user err Error: Login loop detected!(…)
cdn.c9.io/nc-3.1.2902-803326ed/config/workspace-python-plain.js:22915 Reconnecting while already connected/connecting. Abort.reconnect @ cdn.c9.io/nc-3.1.2902-803326ed/config/workspace-python-plain.js:22915
https://api.c9.io/user?access_token=xxx Failed to load resource: the server responded with a status of 401 (Unauthorized)


#3

Workspaces and login seems to be working again.


#4

Exactly the same thing is happening to me.


#5

I’m looking into this, not sure what’s going on yet, seems to be sporadic.


#6

After 13:00PM Here, on Brazil (GMT -0:300) I am seeing a error, failed to fetch user profile (status: 401 data: {“message”:“Requires authentication”,“documentation_url”:“https://developer.github.com/v3”})


#7

Same problem here, Italy after 16 PM today


#8

Same problem here too, worked fine all day but I can’t login at home (7.30 pm)


#9

Same here! I also tried to set a new password, but the link was expired the minute it came.
SWEDEN


#10

I’m also locked out and got work to do. Worked for me earlier today.

I’m getting 401 on login screen.

When trying to recover a new password, it says that the activation link has expired.

I’m in Denmark


#11

Same here! With login and reset the password. Russia


#12

Same here! Can’t use GitHub login nor login password. Slovakia


#13

Same problem (( But I desperately went further: I requested password reset. And no confirmation e-mail ((


#14

And with login to community (problem had solved by login via GitHub account)


#15

The same problem here? we reseted our password clean our laptops cashes, rebooted, still to reinstall the operating system :slight_smile:


#16

I can’t sign in either. Has been like this all day. Completely work day lost…


#17

We’ve identified the cause as our sessions database has gone out of sync between regions which is what’s causing the sporadic issues. We’re working on re-syncing it now. Please see http://status.c9.io for more information.


#18

Thanks! Waiting for it to boot up!


#19

The databases have resynced and everything should be working again. Thank you everyone for your patience. The cause appears to be a networking issue with our host and we’ll be following up with them to see what happened.


#20

It is work! Thank you guys!