Can't save the file. Am I missing some basic common knowlege?

laravel

#1

Ctr+S produces the above error.
Is this a bug? Is there a setting I need to change? Chown or Mod?

----Trying to change ownership—
I don’t know which user to change ownership of the workspace to. I’ve tried the name in the terminal just before the colon in the command line, which is an invalid user. I’ve tried random newbie stuff like changing ownership to sudo:ubuntu…the ownership changes but, the saving does not work even when I give the user and group owner full permissions. I tried to list current users and it lists no names at all; apparently I’m a ghost to myself.

Could someone advise me on how to change the permissions. I’m not using ssh. This is just a simple, newly made private workspace. Thanks in advance.

----Solution—
So, I was trying to run some laravel stuff. A regular setup prior to laravel installation will run if you follow the instructions but, after the LV installation won’t do anything. It IS a permissions issue. I did not know what was the username I was logged in under, though. So to know who you are you type the command “whoami” I’m assuming everyone is ubuntu. Then you chown ubuntu:your-group-if-necessary for the entire workspace. So that command would be “chown -R ubuntu: ~/workspace”.

I’m still new so if this piece of information has created a security issue for me or anyone who would follow this advice, please let me know so I can update.


#2

Indeed the message indicates that there is a permission problem. This could be because:

  1. The owner is not set correctly. Use sudo chown to change the owner of the file or directory
  2. You are in the group that can write, but the group doesn’t have write rights. Use sudo chmod +w
  3. If this is an SSH workspace you might have a read-only volume. However looking at the prompt colors in your workspace I think you don’t have an SSH workspace.

#3

Ok, I’m new to this ide and the linux environment. I tried to chown the user my username is engud so I did “sudo chown engud ~/workspace”, it says that user doesn’t exist. Could you give me more detail, please?


#4

Please paste the results of ls -L in that files directory so we can see all the file permissions. You can also invite me to the workspace so I can help you trouble shoot “shadowcodex1”


#5

Thanks, I figured it out going to put it up for others like me who may not know what may look like common knowledge to everyone.