Can't run Rake and WEBrick after bundle update

rails
ruby

#1

Hi everyone!
I just ran bundle update and when I try to run rake db:migrate or WEBrick I get this sentence:

Could not find listen-3.1.3 in any of the sources
Run 'bundle install' to install missing gems.

WEBrick produces Process exited with code: 7

I ran bundle install and bundle update then gem which listen, it finds listen saying:
/usr/local/rvm/gems/ruby-2.2.1/gems/listen-3.0.3/lib/listen.rb => on ruby 2.2.1
/usr/local/rvm/gems/ruby-2.2.3/gems/listen-3.1.3/lib/listen.rb => on ruby 2.2.3

I tried to switch back and forth between ruby 2.2.1 and 2.2.3 using rvm but nothing seems happen when I try to rerun Rack or WEBrick. Also restarting workspace doesn’t work.

Does anyone have a hint? Thanks :slight_smile:


#2

Hi,

Thanks for writing in. My ruby/rails is fairly rusty, so bear with me here :blush:

A few things to check:

  • What is your ruby version in your bundle? That runs your app?
  • What’s your default ruby version in the workspace? (use rvm list in the terminal to get a list of all ruby versions)
  • Can you tell me the line in your gemfile that installs listen?

Regards,
​Mutahhir


#4

@Fenuj this is a somewhat different issue from the original post. Can you post details about the error you’re seeing on a new thread? Thanks!


#5

Thanks @mutahhir but I just fixed it right now :slight_smile: . I changed my default ruby version to 2.2.3 using the command rvm use --default 2.2.3.
I discovered you actually need to have ruby 2.2.3 as the current AND default ruby version to run listener 3.1.3. Now Rack and WEBrick works with ruby 2.2.3. Hope it can help who has the same problem :slight_smile:.