Can't change Virtualhost (permission denied)


#1

Hi,

I try to edit the /etc/apache2/sites-enabled/001-default.conf but I got a permission denied message.
The fact is that I installed Laravel and I would like the Virtualhost to point to /workspace/public instead of /workspace.


#2

/etc/apache2/sites-enabled/001-default.conf is editable by the root user so just be sure to use sudo. If you use vim to edit files, you might try:
sudo vim /etc/apache2/sites-enabled/001-default.conf

As a workaround, you may be able to move all files from /workspace/public to /workspace and proceed without changing any virtualhost files.


#3

Hi Bradydownlng ~
Sorry for digging up this old thread but it’s the only one I could find that addresses my exact issue.

sudo nano /etc/apache2/sites-enabled/001-default.conf
gives me permission denied message when I try to save and exit.

Any ideas? Thank you.


#4

Can you check if this is the case in a brand new workspace as well?


#5

I’m getting this issue with a brand new workspace:

cp: cannot create regular file ‘/opt/go/bin/glide’: Permission denied
Fail to install glide