Can't access my Workspaces


#1

I teach special education kids how to use technology. We’ve been using C9, but now we can’t log in. Instead we are getting:

Unable to access your workspace

/mnt/shared/sbin/node
Could not spawn ssh client: Error: spawn ENOMEM

Please help/


#2

I’m having the same issue.


#3

I’ve been having the same issue. I read in another post that ENOMEM means that there isn’t enough memory, but I know that’s not the case with my workspace. I also read to try to restart the workspace. After trying about a dozen times, I finally got in.


#4

I’ve also been experiencing this error, but I found that just refreshing seems to work and allow you to enter the workspace. Hopefully this will get resolved soon though. FYI, using Chrome 53, if you’re using anything else maybe try chrome?


#5

Im having the exact same problem


#6

Same thing. Worrisome. Refreshing the page when the error appears fixes the problem.


#7

Same issue. +1 for refreshing the page when the error pops up.


#8

Having the same issue, refreshing is not seeming to help at this point in time.


#9

@moderators now this is really happening to me. Previously refreshing worked, now it doesn’t do anything. I also tried re-opening the project from the dashboard, which didn’t work either. Here is my workspace: https://ide.c9.io/dannytech/robototes-website. Can you see if you can join it?


#10

This was the result of one of our servers running out of memory. We’ve since corrected this and will be evaluating how to prevent this in the future. All your workspaces should be all set now :thumbsup:


#11

I have this issue up again, what i’m supposed to do?


#12

/mnt/shared/sbin/node
Could not spawn ssh client: Error: spawn ENOMEM


#13

me too, have same problem