Cannot save png after cropping in built in image editor

workspace

#1

I have a png in my project.

It opens fine in the built in image editor and im able to crop it.

Issue is when i click save in menu or closes image and select save in the “you wanna save?” dialog, nothing happens.

And file is not updated with the new crop i just applied.

( It doesn’t even close the open file pane, when i close file and select save in dialog.)

I can download the cropped image with chrome by right click -> save file.

This saved file is cropped, as is should be, and i can upload it, delete other file and then rename.

So everything actually works except saving the image directly.

Thought it was a permissions related thing, but permissions are the same as other files in same folder.

I can open edit and save text files - both php and css have been tested.

Any obvious reason for this behavior?

EDIT:
Just tried to use “save file as” in IDE. Same result - nothing is saved to disk.


#2

Any big fat errors in your browser console when you click save?


#3

Thank you for the reply.

No idea why i didn’t think of that.

Here is the error in the console:

It shows when i click the save button in the dialog that shows when you close a unsaved file.

If i edit the image and click save in menu, it gives a different error:

Any ideas or should i start digging?


#4

Thanks for the detailed report!
We have found the cause of the issue and will fix it soon.


#5

I’m having this same issue with all image types, do you have an eta to when this will be fixed?


#6

I have also experience this issue, its been going on for at least a week since I last tried to use the image editor.
Besides this, Cloud9 has been an awesome IDE and I’m super glad that I can use it. Thanks for making such an amazingly integrated environment!