Cannot Preview a Meteor App within a SSH Workspace

ssh
meteor

#1

I’m using a Cloud 9 SSH workspace to test out developing on Meteor on a Google Compute Engine instance using Cloud 9.

I try to run both of the following commands but still get a blank screen when I preview the basic default meteor app:

meteor --port $IP:$PORT
meteor

Then, I try both of the following addresses:
http://localhost:3000/
http://127.0.0.1:8080/

In both cases, I get “localhost unexpectedly closed the connection” in the browser window. I also tried the IP address of the server, and the IP address of the server + :3000 as a last hope. The firewall of the network is closed to all non-ssh traffic, but I don’t think that should be an issue because I am using localhost, and I am not trying to preview or run the application over an external network.

Maybe this is just something you can’t do in an SSH workspace? I prefer not to open the network and serve the app over the external network for development due to security issues. Basically, my goal is to use a much more powerful machine for development on google cloud (than what I have at home), and use Cloud 9 as both the IDE and the test environment for viewing the meteor app.

UPDATE: the run feature did not work either.


#2

One alternative I found was to use a SSH tunnel as suggested here:

https://superuser.com/questions/891895/how-to-access-webpage-running-on-remote-server