Cannot login to Wordpress Installation

wordpress

#1

I cannot login to the wordpress installation on one of my workspaces, I got kicked out and cannot log back in. The front end still works ok. I saw a similar post and the advice was to create a new user via PHPMyAdmin. I have done this but its just the same result, I am unable to login with the newly created user account as well.


#2

Do I need to add any special information to get a reply about this?


#3

I there anyone out there who can help? I need to progress this job one way or another and would prefer to keep using cloud9 but this seems more than a bit flaky!


#4

did you create workspace using wordpress templete?

if so, modification config can cause problem. simple way is create new workspace using templete and try again.

if you install wordpress manually and adjust mysql and other’s options, you might miss some config like mysql user accout and wordpress account for accessing mysql. if you wanna this way, try again step by step. i also have had trouble in this progress.

for more advise, reply more information how you create workspace, how got wordpress, what commands you tried,and so on.


#5

HI, I just did the standard WordPress install, nothing complex at all. Was working away on it for a good week or two then suddenly kicked out and can’t log back in.


#6

is “standard” means “use templete” (like screenshot) or “install guide in wordpress webpage”?


#7

Yes, just using the WordPress install option as in your screenshot


#8

you said “frontend still works ok”. so i understand apache server is running.

and “cannot log back in” means you can access wordpress main page and login page. right?

then it is about database(mysql) status or database permission. please check mysqld is working and check user permission in mysql is correct for wordpress config.

IF you cannot see any page of wordpress, another problem like you changed domain setting in wordpress or move wordpress files to other path, so on.


#9

Yes I can see the wp-admin login screen, it just won’t accept my credentials.

I didn’t change any wordpress settings. Was only working on the functions.php file, and on pages and on a specific plugin (gravity forms).


#10

YES

these detail information is important and needed.

if you have original copy of functions.php, try roll back that file. you can get this file by create another wordpress workspace.

by the way, is there any message in wp-admin login screen? i think some message exsits.


#11

Thanks for your help so far.

Ok, I tried this “mysqladmin” on the command line and got a bunch of options and so I assume this is running ok. Not sure how to check permissions etc.

Message on wp-admin says incorrect password (its not - have checked on database).

I have tried removing all the customisations made on the functions file but it makes no difference.


#12

Just to really clarify. This is really my first couple of tries with Cloud9. I’m frontend and therefore haven’t adjusted any project settings from within could9. In terms of the cloud9 interface, all I have done is created the project using the provided “WordPress” button and then Ran the project and so this must be about the most standard implementation you could have for cloud9. I have tried this on one other website and never ran into any trouble for the whole of the development of it taking 2 months. This is the beginning of another project but I have spent a lot of time setting up some Advanced Custom Post types and a form and would hate to lose all that work to start again. I really don’t expect that this has anything to do with the development I have done so far. It seems like a system error to me - I really appreciate your help trying to debug @litrine - but do you think that the server permissions could just have changed by themselves. The stuff I’m doing is so basic that I just think it has to be something more to do with external factors.


#13

could you invete me to your wordpress memeber? (readonly permission is enough)


#14

Thanks but I don’t seem to have the option to add anyone to a workspace.


#15

in topright, Share button.

below Invite People type my username orbit and press invite button


#16

it looks server down.

and you can talk with me in collaborate sidebar


#17

So you CAN login with a restricted access wordpress account (author) but cannot login with an administrator account.


#18

Ok, so this was fixed in the end. Thank you to @litrine for helping debug. I was able to find an older user account and login with that - not sure what I would have done otherwise!

In case anyone is looking the solution of making a new account on phpmyadmin did not work for me. Possibly as when a user is added it adds encryption to the password? Not exactly sure but I didnt need to start investigating that.


#19

thanks for updating and for keeping this up.
obviously thanks to everyone else for answering! been having same issues. will try to fix it now. thanks again.