Cannot install Browserify globally in cloud9


#1

Hi! I need to install browserify globally in order to run nodejs features in the browser.
When I use the command: npm install -g browserify.
I get the error message :
"RR! rofs This is most likely not a problem with npm itself
npm ERR! rofs and is related to the file system being read-only.
npm ERR! rofs
npm ERR! rofs Often virtualized file systems, or other file systems
npm ERR! rofs that don’t support symlinks, give this error.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ubuntu/workspace/npm-debug.log"

I read in some blog posts that updating npm might be a solution. I used the “$npm update” command to update npm and tried to install browserify afterwards, but still got the same error message.

I would really appreciate any help. Thank you


#2

npm update is designed for updating npm packages, not npm itself. If you want to update npm, please run npm install -g npm. After that, make sure the version is npm 5, and then try again.


#3

Thank you Danny. I ran the command you mentioned and got the same error message. I ran $ npm -v and my version is 2.14.12.

I went to the npm page https://www.npmjs.com/package/v5/tutorial. I ran $ npm install v5 but still my version has not been updated.

I’m running a Windows machine(windows 8.0)
Am I doing something wrong?.
I would appreciate the help.


#4

looks like you are using the node from /mnt/shared, instead of the version from nvm.
Try using nvm