Cannot get meteor to run on C9. Are you no longer supporting meteor?

meteor

#1

I have been trying to get my meteor app running for the last two weeks. Out of sheer frustration I deleted the workspace and rebuilt it multiple times, refreshed all my packages and did everything under the sun I could think of. It tries to build the app, then gets stuck at “Starting your app…” and never completes. I let it run for hours at that stage and it never completes.

So this morning, on a newly created workspace, I installed meteor and created the basic “hello world” app, and when I tried to run it got the same “Starting your app…” and it never starts. Did you guys pull support for meteor? I’m not interested in using this if I can’t build with meteor.


#2

You might try my suggestion in another post:

Also, remarkable, there is someone in the world who keeps more tabs open than I do.


#3

As remarkable as that expression which made me laugh so loudly :smile: Hahaha!


#4

@dtrimsd Yeah I have way too many things going on in my browser. I’m working on being more zen and dropping down to only 10 tabs at a time, but I want to learn ALL THE THINGS! :wink:


#5

May it will be useful for someone for Meteor:

  • I create new workspace using template Node.js,
  • Install meteor in terminal of a new nodejs workspace (bash) with command curl https://install.meteor.com/ | sh,
  • create new meteor project or copy my meteor project files to app directory,
  • create tab NewRunnerConfig, set meteor project app directory as working one,
  • Run.
    And the project works at the default address (that is seen also in the Run tab message)

By the way, I never use “–port $IP:$PORT” - is it really necessary for something :slight_smile: ?
I must say that I am new both in Meteor and in WWW-programming in general :blush: .


#6

It is necessary if you want to view your site in another tab with your c9 url. Otherwise you cant use localhost outside of ide.


#7

Sorry, but I really can see my site with my c9 url in another PC and in my smartphone (just now I tried to do that and have seen the site). So till now I can not understand the necessity of “–port $IP:$PORT” :slight_smile: But I would be glad to understand it, because I plan to use that address for some period of developing the site, for other my coleagues may see and try its functions (it will be site for psychological testing).
May be it is necessary only when I run Meteor in bush command line, but not necessary when I use Runner - Meteor?
By the way, that Runner is one of the reasons why I think that c9 is the best place for Meteor beginners, it is the easiest way to develop working site on Meteor (I tried about 5 other services and all they was more difficult in using).


#8

I was able to resolve the “Starting your app…” issue by executing meteor with the command line:

MONGO_URL=mongodb://127.0.0.1:3001/meteor meteor --port $IP:$PORT --verbose

This post help me identify the issue: https://forums.meteor.com/t/meteor-stuck-at-starting-your-app/25592/7 ( do not use “set” as defined in this article).


#9

I wrote a short procedure to create Meteor app in C9 in stackoverflow. http://stackoverflow.com/questions/40427413/create-a-meteor-app-on-cloud9/40442104#40442104