Cannot create Salesforce Workspace

salesforce

#1

Logged out of Salesforce - closed all windows - Logged in (sandbox) -
then in c9 clicked on create new Salesforce workspace - https://c9.io/new/salesforce
select Sandbox … and always get

We could not authorize your Salesforce account. You will be redirected to your login page to resolve this issue.
This workspace is not linked to a Salesforce account

Sometimes, I get the Salesforce Auth dialog - usually not - but does not make a difference.
Tried that in Chrome, FF, Safari - always same result


#2

Hi,

It could be that your Cloud9 account is still linked to the wrong Salesforce account. Can you try re-linking your account at https://c9.io/auth/salesforce?

Dana


#3

Thanks - that worked - for a new Workspace you should always force authorization.
A related topic: after refreshing a Sandbox do I always have to delete the old workspace and recreate a new?


#4

Hi,

Sorry for the late reply! I am not sure what you mean by refreshing the sandbox. Could you please elaborate on that?
In general, if you would like to ensure you do not have to deal with old traces of (Salesforce) sessions, you can log in through an incognito window. This way you can be sure that you are working with fresh cookies/links

Regards,
Dana


#5

We deal with 20+ customer accounts … so rather than hoping that the browser has the right Salesforce cookie, you should always force (re)authorization for a new workspace - i.e. use https://c9.io/auth/salesforce.
As mentioned I used an incognito tab and that did NOT help.