Cannot Click Checkbox To Set Application To Public

nodejs

#1

Hello, when I click “share” in the top right of my screen, under “Links to share” I am unable to click the checkbox to set the application url to public. It is grayed out and unclickable. This seems like a simple problem, but I am new to c9 and can’t find anything by searching.

Anyone know why I can’t click the checkbox or what I can do to set my application to public?

Thanks!


#2

Could you, please, show a screenshot of the share dialog?


#3

Hello! Thank you for your reply!

Here is a screenshot of what I see when I click “share”.


#4

this is a bug in rendering of flat theme, which doesn’t show checkbox state for disabled checkboxes. When workspace is public application and preview are public as well.


#5

Hmm… ok the reason I wanted to set my application to public in the first place is due to advice given on stack overflow: http://stackoverflow.com/questions/33441369/xmlhttprequest-cannot-load-cloud-9-io

I am experiencing an “access-control-allow-origin” warning? Can you help me with that? Thanks!


#6

For which url do you get this error? if it is something from your app, you need to set that header https://developer.mozilla.org/en-US/docs/Web/HTTP/Access_control_CORS


#7

It was something from my app, but the api I was using did not support CORS. I found a new api to work with and the problem went away. Thank you so much for all of your help harutyun! I am up and running now!


#8

Hi, I am experiencing the same issue with one of my workspaces. I am trying to use curl to send a POST request to my app, but get a “Cannot POST (API)” error.

The workspace is set to “Public” , and I am not using the Flat Theme (regarding the above comment), but my Share modal still looks like this:

image

Is there any way to enable this checkbox, so that I can set my application preview to public? Thanks!

  • Michael

#9

@mikalaranda your application preview and the workspace itself are public


#10

Hi Harutyun,

Thanks for your reply! I do realize now that the “Cannot POST” issue was entirely independent of my workspace’s settings, and things are working now. Appreciate your help.

Best regards,
Michael