Can I install GLPK?

rails
ruby

#1

Is it possible to install GLPK (http://www.gnu.org/software/glpk/) on Cloud9? I am trying to use it with the rgplk gem (https://rubygems.org/gems/rglpk). Do production systems (e.g., Heroku) typically support the installation of such?

My Unix skills are not ideal, so I’m not sure what commands to use (and if it matters where I run them).

Thanks!


#2

Yes, you certainly can install GLPK. The homepage you referenced has download instructions so just follow those.

Further than that, you’re best honing your Linux skills since you’ll probably need them as you move forward developing with GLPK :wink:


#3

Hi, Brady. Thanks for your response. I should have elaborated.

I tried running ftp from a C9 terminal, but the command was not found:
> $ ftp

bash: ftp: command not found

Is there a way to ftp from a C9 terminal?

I didn’t know, so I ftp’d the glpk files to my local machine.

I then used File / Upload Local Files… to get them to C9.

I followed the directions on p. 185 of http://kam.mff.cuni.cz/~elias/glpk.pdf.

Specifically, I ran:

gpg --keyserver keys.gnupg.net --recv-keys 5981E818 gpg --verify glpk-4.60.tar.gz.sig

The output of the second command was:

gpg: Signature made Fri 01 Apr 2016 10:49:32 AM UTC using DSA key ID 5981E818
gpg: Good signature from "Andrew Makhorin mao@mai2.rcnet.ru"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: A2B5 6CCB 4222 0C06 4813 35BA D17B F230 5981 E818

Is there a point to running gpg --verify if the key is not certified? Should I be concerned about this?

I then ran:

gzip -d glpk-4.60.tar.gz tar -x < glpk-4.60.tar
cd glpk-4.60 ./configure
make make check
$ make install

The output of the last was:

Making install in src
make[1]: Entering directory /home/ubuntu/workspace/lp1/glpk/glpk-4.60/src' make[2]: Entering directory/home/ubuntu/workspace/lp1/glpk/glpk-4.60/src’
/bin/mkdir -p ‘/usr/local/lib’
/bin/bash …/libtool --mode=install /usr/bin/install -c libglpk.la '/usr/local/lib’
libtool: install: /usr/bin/install -c .libs/libglpk.so.40.1.0 /usr/local/lib/libglpk.so.40.1.0
/usr/bin/install: cannot create regular file ‘/usr/local/lib/libglpk.so.40.1.0’: File exists
make[2]: *** [install-libLTLIBRARIES] Error 1
make[2]: Leaving directory /home/ubuntu/workspace/lp1/glpk/glpk-4.60/src' make[1]: *** [install-am] Error 2 make[1]: Leaving directory/home/ubuntu/workspace/lp1/glpk/glpk-4.60/src’
make: *** [install-recursive] Error 1

I don’t know why it says the file exists (and thus why installation fails):

$ ls /usr/local/lib/
python2.7/ python3.4/ site_ruby/

Am I doing something wrong? Thank you for your help.