Can I disable autocompletion in Ace editor?


#1

Since I don’t know what these pop-ups are called, I’m including a screenshot of how they’re showing up today here:

[This’s an early post for my handle, and the forum’s disabled adding other screenshots, for example, of my editor settings, so I’ll see if the forum bots will let me addd a few of these in a followup post in this thread.]


#2

I searched for and found something that looked similar in these community forums, and found suggestions to turn off autocomplete in the editor to disable this kind of pop-up, which looks similar (they look similar, but are differently colored) to this one in the FAQs:


#3

I think I already do have autocomplete turned off, as shown in my Language input settings here:


#4

I’ll also include here a screenshot of my Ace editor settings:


#5

I don’t see any other settings for this there – can you please tell me what I’ve missed?


#6

The “complete as you type” option disables Cloud9’s behavior of showing the popup with any character you press (e.g., the letter c). We don’t currently have an option to disable completion completely: there are still trigger characters in certain languages that show the completer (particularly the “.” in JavaScript). Is there any particular reason you would want to disable those as well?


#7

Thanks for explaining. I’m hoping that your question is just a rhetorical one!


#8

Autocomplete interferes with Emmet. If i press “p” then tab, emmet should give me a <p></p>. Instead I get the first option in autocomplete, <input type="password" name=""/>. This is not helpful, and I have no idea why pressing p and tab would lead me to an input type=“password”. Seems arbitrary given I only entered one letter. We need a way to disable autocomplete.