Can Cloud9 handle C++ GUI windows

cplusplus

#1

Hello there! I was just asking if C++ Can handle like creation of windows, for example using SDL, OpenGL, GLEW? I still didnt try them out(will soon), but i was just asking if Cloud9IDE Can handle windows for my future use(about a monthish… or less). Reponse would be appreciated!


#2

I think the solution for this will be the same as what’s in this thread :thumbsup:


#3

Im not sure if that talks about C++, more like Python and JAVA. Ill come make a topic again, when i actually work on GUI’s for C++… this was just for my future awareness… Thanks though @bradydowling!


#4

Hmm, I thought it applied but either way, I think this should be helpful as well. Correct me if I’m wrong though :wink: https://github.com/fjakobs/cloud9-vnc


#6

Nvm @bradydowling i take that back… I dont see how to put the toolchains though… and set it up. Im currently asking this on stackoverflow too… would be awesome to know how to set up SDL Or any C++ GUI Window on Cloud9IDE:

http://stackoverflow.com/questions/37220104/how-to-activate-c-sdl-in-cloud9ide


#7

Ok @EtienneWan helped me out get the window to work… and we used:

g++ main.cpp -o main.out -pthread -std=c++11 `sdl2-config --cflags --libs`

but now how to output it on a window!


#8

After a while, i have figured out that Cloud9IDE Does not Support this feauture… Im going to have to use my Visual Studio :frowning: . I hope @cloud9 supports this feauture soon…


#9

It’s been quite a while, but I think my project would have helped here, https://github.com/acabey/cloud9-vnc


#10

How would that help?


#11

It gives you a desktop environment over VNC


#12

I’ve used C9VNC for OpenGL. The only problem I’ve run into is lag.


#13

When I can get it to work with no issues C9VNC is a really great tool. The input lag is a little iffy but other than that it works perfect. Although I am personally getting exit status 1 from fluxbox when I run it now. It’s wierd


#14

Which fork are you running? Most versions of c9vnc were just clones of a C9 developer’s proof of concept and did not update the project or make improvements. Because every fork I could find was inactive, I spent time to rework the whole system (install and runtime) to run under daemon processes which has in my experience eliminated any errors that I saw in other forks.

I also allow authentication if that matters to you.


#15

I actually didn’t fork it I just cloned the repo straight into my
workstation. It seems to work by magic now lol. Fluxbox wasn’t working and
now all of a sudden it is and I didn’t edit the supervisor file yet. It’s
wierd


#16

@acabey hey acabey i’d like to know if there is any chance that VNC will support audio output?


#17

There’s no integrated solution with noVNC, but I’m looking into using Janus gateway to support audio


#18

I cant do anything exept hover with that x cursor… it becomes a point cursor then changes to x cursor after a little…

Terminal :

amanuel2:~/workspace/utils/novnc $ ./run.sh 
VNC client running at https://cppsdl-amanuel2.c9users.io/vnc.html
Starting c9vnc daemon
Unlinking stale socket /tmp/supervisor.sock

I normally right click > applications > terminal to open terminal up and then run my c++ app


#19

For now just run source ~/.bashrc but I will integrate this fix in an update. Thanks for notifying me

EDIT:

Issue is now fixed on github. To update just uninstall, git pull and reinstall. I am working on a better way to update.


#20

Now its wierd… It says :

amanuel2:~/workspace/utils/novnc $ sudo ./run.sh
VNC client running at https:///vnc.html
Starting c9vnc daemon
amanuel2:~/workspace/utils/novnc $  

and when i ignore the url and i think i remembered the right url to run the vnc http://cppsdl-amanuel2.c9users.io/vnc.html but i still get No application seems to be running here!


#21

Can you try completely uninstalling (sudo /opt/c9vnc/uninstall.sh) then reinstalling with the latest update?