C9 standalone stopped working


#1

Hi,

I’ve been running c9sdk on a Ubuntu server. Recently it stopped loading workspaces with the error messages shown in browser console:

Failed to load resource: the server responded with a status of 499 (unknown)
http-xhr.js:126 HTTP error 499: {“error”:{“code”:499,“scope”:“standalone”,“message”:“VFS connection does not exist”}}
xhr.onload @ http-xhr.js:126
vfs_client.js:105 Uncaught TypeError: eio is not a function

I’m starting it (usually with pm2) with the following options:

node ./server -p xxxx -l 0.0.0.0 -a test:test -w …/xxxxx
Starting standalone
Warning: running Cloud9 without using HTTP authentication.
Run using --listen localhost instead to only expose Cloud9 to localhost,
or use -a username:password to setup HTTP authentication
Connect server listening at http://real_ip:xxxx
Using basic authentication
CDN: version standalone initialized /home/xxx
Started ‘/xxx/configs/standalone’ with config ‘standalone’!
Cloud9 is up and running

I’ve tried running c9 in debug mode and without plugins, no help. Also tried rebooting the whole server. Only thing that could have caused it is restarting mongod service with some port/ip changes - however I tried rolling those back with no effect (they weren’t conflicting with c9 anyway).

Any help greatly appreciated!


#2

Full c9 reinstall solved the issue.


#3

cd to cloud9 core directory and typing:

rm node_modules/engine.io* -r && npm i

#4

This works for me. I have to do this so often that I gave it its own alias:

alias c9fix="(cd /path/to/c9sdk && sudo rm -r node_modules/engine.io* ; sudo npm i)"

Do you know what causes it? Is it a bug?


#5

I think if the server is forced off. like kill proccess or shutdown machine