C9.ide.desktop not working


#1

I’m trying to use the matplotlib python library but get an error about $display not being available. I’ve looked arounf and i clearly need to install a gui backend to make this work.

c9 install c9.ide.desktop seems to be the answer but once installed with websockify the feature doesn’t seem to appear on the view menu.

Any idea what i’m doing wrong.

Thanks
DAmian


#2

You’ll need to go into Preferences (gear icon, top right), then Experimental, and enable “Load custom plugins” and “Load Plugins from Workspace,” I believe (@moderators can you confirm those are the correct options)


#3

Thanks Danny I'd already done that. Ive followed the setup instructions as described but it doesnt seem to work. Ive used the alternative system that has been posted.


#4

I posted an alternative solution that worked for me in the DISPLAY thread.

https://community.c9.io/t/how-to-set-display-in-my-workspace/1646/22


#5

Hey guys I know it’s really late on reply here. But I’m going to be working on updating the c9.ide.desktop plugin.