C++ code not updating correctly?

workspace

#1

Today I was gonna try to debug some code but for some reason, all the new "“couts” I add are not outputing. I tried adding simple things like “Test” and they aren’t outputing despite all the previous couts working fine. So to test c9 I tried adding a cout to another script, and even that one didn’t work. Yesterday everything seemed to be working great, so I’m really confused.


#2

Did you try Restarting your Workspace yet? This might fix it up.


#3

I think I found the problem. I didn’t have an endl so even though the code broke at a later step, it never had time to output my test string. Sorry for my confusion.


#4

G’day Brendon,

Just adding onto of what Brady has mentioned, we actually see this issue a lot with our students. We worked out it had nothing to do with cloud9 but the students browsers.

These commands will force the browser to reload and refresh all the resources related to the websites page.

Solution for Mac:
Command + Shift + R

Solution for Windows:
Control + R

Cheers,
Byron