Bug which prevents me from accessing my project

php

#1

Hey, I have a question similar to ones I found on forums, but I couldn’t find the exact question:
I can’t access my files in my project. When I open it, there is a warning:

Workspace Error:
Unable to access your workspace

/mnt/shared/sbin/node
ssh process died with exit code 1

I was changing some configurations to share my workspace, when the error occured.
How can I solve this problem?
Thanks in advance,
Nathan


#2

Hey I run into the same exact problem problem this morning and Im looking for a solution as well. I didnt change the configuration though.


#3

Ah, that’s unfortunate.
I’ve found a little way around this:
You can clone your project and this way you can get to your files,
but that’s not the ultimate solution.
Hopefully the C9-team will look into this.
Hope this helps,
Nathan


#4

I’ve run into the exact same issue this morning. It was working fine yesterday evening


#5

I found a solution, although it might be a bit tricky to execute: If you manage to restart the your server (by pressing “memory/cpu/disk”->restart in the top right corner), you will get thrown out one last time, but the next time you access it, everything will be as before.

(this worked for me anyway)


#6

Restart server didn’t work for me )-:


#7

The only thing I did was change my C9 password ?


#8

I can’t even clone my project because C9 tells me I’ve run out of hosted workspaces. I only have 2.

2 workspaces

Yet I can’t clone the defective one.


#9

Hey Matthias,
can you be a bit more specific? I can’t find the memory/cpu/disk (might be my fault though)


#10

And now mine is working again.


#11

Update: It’s working again for me, don’t know how, maybe the issue solved itself
Thanks for the replys anyway!


#13

apparently, its working for everyone now, so maybe my “restart” solution was just a coincidence…


#14

Hi there! Mine has just worked again. Maybe there was some bug with the SSH. I have some workspaces but only 1 workspace was dead. After about 15 minutes, I was kicked out automatically and I had to log-in again and everything was fine.

By the way, I cannot find the “restart button” like Matthias said.


#15

@nguyentamgm


#16

in the top right corner, you have several buttons. From left to right:

  • cloud9 logo that takes you the the dashboard.
  • the gear button for settings
  • share
  • “memory/cpu/disk”: this is my description of this button. It displays the current memory/cpu/disk usage of your project.if you press this, you get a drop-down with some information about the workspace and some options. One of these option is restart.
  • logo off all logged in users

I hope this helps…


#17

Thanks, this was a much simpler way to explain :stuck_out_tongue:


#18

Thank you for the screenshot but my case was a bit difference.

I saw an error message and a button to get back to the Dashboard. I tried to turned off that pop-up and tried to open that Status panel. But there was a class named “disabled-iframe” at “body” tag or somewhere I don’t remember. And it was stopping me from restarting the workspace.

Anyway, thank you for your quick reply! :smiley:


#19

Didn’t work for me either.