Before, I could see the rails default page. Can't see it now

rails
ruby
ruby-on-rails

#1

I’ve tried to search for the answer to my question but couldn’t find it. Apologies if this has been answered already.

So I’ve been doing a Ruby on Rails course from Udemy, and after create an application, I decided to start from the beginning and recreating the application.

lol, I got stuck right at step one :frowning:

So I went to my cloud9, went to my terminal where my rails projects were and created a new rails project

rails new myApp
Afterwards, I went into it cd myApp, then ran rails server

I noticed before, it would say webBRICK, but now it says puma

Also, I get this:

=> Booting Puma
=> Rails 5.1.4 application starting in development
=> Run ' rails server -h ' for more startup options
Puma starting in single mode...
* Version 3.10.0 (ruby 2.4.1-p111), codename: Russell's Teapot
* Min threads: 5, max threads: 5
* Environment: development
* Listening on tcp://localhost:8080
Use Ctrl-C to stop

Usually, at the end of the 2nd line, there is in development http://localhost:3000 But I’m not getting that at all now.

I’m basically just trying to see the default rails page. Have tried clicking ‘preview’ and run project but neither get me to show the rails page.

So I’m just wondering, is there something I’ve done to change things?

I’ve tried multiple things.

rails s -p $PORT -b $IP, killall ruby, creating a new workspace, rails s -p 3001 changes the tcp location, but I’m not sure how to load up the default rails page. It’s annoyed me as I was able to see the rails page I made before but now, nothing happens/just can’t even find the rails page.

(The course I did installed Heroku and github credentials. I’m currently on a new workspace in cloud9).

Just wondering if there is anything else I can try?

Thanks


#2

Ok, I have no idea, but someone asked me to try running the rails server again with

rails s -b $IP -p $PORT

This worked.