Bash command key shortcuts somehow overloaded


#1

Many of the bash shortcuts do work but for some reason Ctrl-K is overloaded with some kind of clearscreen command. Since I use Ctrl-K to clear to the end of the line I am constantly executing the wrong commands :frowning: .
Here is a doc that shows all the command shortcuts in emacs mode which most shells seem to default to (or I end up choosing that mode if they are not)


Is there a way to “unhook” Ctrl-K since it’s not mentioned as a keyboard shortcut for the terminal window in the preferences.
Now it seems there is another post “Shortcut to clear Immediate Window” which seems to be asking for something like Ctrl-K even though there is already an entry in the preferences for it.
Thanks
Andy


#2

Same here, if I work from a Chromebook, then Ctrl-K doesn’t kill to the end of line.
Although, if I work from a Mac (using Chrome browser), then Ctrl-K works as intended.

Also, to go the end of line, I often use Ctrl-E, but this neither works when I work from a Chromebook. It’s annoying. For now I’m using bash vi mode to avoid this problem.