Backspace visual is constantly indented


#1

Whenever I try to delete a character, the backspace symbol is way ahead. At the moment if I backspace like the picture is shown, it will delete the ‘;’ character and not cancel the whitespace. It is very frustrating and I can’t fix it. I’m not sure what the problem is it?

Also, if I move the symbol closer to the text so it’s just before the ‘;’ sign and press backspace it will delete the ‘.’ sign. So, it seems that the backspace is forwarding itself to 7 spaces?

This is a consistent issue across all my work-spaces, and I have tried to create a new one where the problem still persists.

I’m not sure if it’s something to do with my keyboard, but I’m not having this kind of issue anywhere else including on editors on my OS.


#2

Hi
Looks like you are using non-monospace font which is causing the issue.
Did you change the default font-family setting? if yes try opening ide with ?reset=1 to reset all settings to their defaults.


#3

Hi Thanks for the reply,

I haven’t knowingly changed anything, I’ve just left my workspace for the weekend and then starting it back up today it started happening.

I’ve looked into the settings and reset everything, even starting another new workspace to see if it works but still the problem is there. The font family listed is “Ubuntu Mono, Menlo, Consolas, monospace”.

Maybe for some reason I cannot find any of the fonts on my system? Is there a place where I can download them or something? (I have already done the necessary restart computer check)

Here are my user settings;

{
    "ace": {
        "@animatedScroll": true,
        "@antialiasedfonts": false,
        "@behavioursEnabled": true,
        "@cursorStyle": "smooth slim",
        "@displayIndentGuides": true,
        "@fadeFoldWidgets": true,
        "@fontFamily": "Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace",
        "@fontSize": "12",
        "@highlightActiveLine": true,
        "@highlightGutterLine": true,
        "@highlightSelectedWord": true,
        "@keyboardmode": "default",
        "@mergeUndoDeltas": "off",
        "@overwrite": false,
        "@printMarginColumn": "80",
        "@scrollPastEnd": "0.5",
        "@scrollSpeed": "2",
        "@selectionStyle": "line",
        "@showFoldWidgets": true,
        "@showGutter": true,
        "@showInvisibles": false,
        "@showLineNumbers": true,
        "@showPrintMargin": true,
        "@theme": "ace/theme/cloud9_day",
        "@useWrapMode": false,
        "@wrapBehavioursEnabled": false,
        "@wrapToView": true,
        "statusbar": {
            "@show": true
        }
    },
    "breakpoints": {
        "@active": true
    },
    "build": {
        "@autobuild": false
    },
    "collab": {
        "@show-author-info": true,
        "@showbubbles": true,
        "@timeslider-visible": false
    },
    "debug": {
        "@autoshow": true,
        "@pause": 0
    },
    "findinfiles": {
        "@clear": true,
        "@consolelaunch": false,
        "@fullpath": false,
        "@project": "/",
        "@scrolldown": false
    },
    "format": {
        "jsbeautify": {
            "@advanced": {},
            "@braces": "end-expand",
            "@indent_inner_html": false,
            "@jslinthappy": false,
            "@keeparrayindentation": false,
            "@preserveempty": true,
            "@space_before_conditional": true,
            "@unescape_strings": true
        }
    },
    "general": {
        "@animateui": true,
        "@automerge": false,
        "@confirmexit": false,
        "@confirmmerge": true,
        "@downloadFilesAs": "auto",
        "@preview-navigate": false,
        "@preview-tree": false,
        "@revealfile": false,
        "@skin": "flat-light",
        "@treestyle": "default"
    },
    "key-bindings": {
        "@platform": "auto",
        "@preset": "default"
    },
    "language": {
        "@continuousCompletion": true,
        "@enterCompletion": true,
        "@hints": true,
        "@instanceHighlight": true,
        "@overrideMultiselectShortcuts": true
    },
    "metadata": {
        "@undolimit": "100"
    },
    "openfiles": {
        "@hidetree": false,
        "@show": false
    },
    "output": {
        "@backgroundColor": "#e0e5e7",
        "@foregroundColor": "#333333",
        "@keepOutput": false,
        "@nosavequestion": false,
        "@selectionColor": "#aebabf"
    },
    "preview": {
        "@default": "preview.browser",
        "@onSave": false,
        "@running_app": false
    },
    "projecttree": {
        "@hiddenFilePattern": "*.pyc, __pycache__, .*",
        "@scope": false,
        "@showhidden": false
    },
    "runconfig": {
        "@debug": true,
        "@saveallbeforerun": true,
        "@showruncfglist": false
    },
    "tabs": {
        "@asterisk": false,
        "@autoclosepanes": true,
        "@show": true,
        "@title": false
    },
    "terminal": {
        "@antialiasedfonts": false,
        "@backgroundColor": "#eaf0f7",
        "@blinking": false,
        "@defaultEnvEditor": false,
        "@fontfamily": "Ubuntu Mono, Menlo, Consolas, monospace",
        "@fontsize": "12",
        "@foregroundColor": "#000000",
        "@scrollback": 1000,
        "@selectionColor": "#bed1e3"
    },
    "tour": {
        "@default-complete": false
    },
    "welcome": {
        "@first": true
    }
}
```

#4

Which os are you using? On windows try searching google for “download consolas”


#5

Windows -

I can confirm I have “consolas” installed in ‘C:\Windows\Fonts’ directory.

Still not fixed it unfortunately.

Do you know what else could be causing the problem?


#6

try changing the setting to "@fontFamily": "courier new"
Also try looking in chrome devtools which font gets applied to the editor


#7

Ah okay I realise what’s happened! (I’m a bit silly)

I was reading an article on Friday which had a font which was not very easy to read, so I used a chrome plugin to change all the divs font-families to “Helvetica”. Obviously I forgot to turn it off afterwards, and it was messing with the cloud9 font settings.

Thanks a lot for helping me realise my mistake!

:+1: