AWS C9 workspace halts after 1 min of work


#1

Dear Community,

I understand perfectly well that this question should not be asked here, but still.

Recently I tried to use C9 on AWS. Carefully following the instructions for creating IAM user, VPC and a subnet I have created a workspace. But the w/s halts to a standstill after about 30 sec / 1 minute of work. Tried this many times in different regions, but all the same: 1 minute regardless to what I do (even if I do nothing) it hangs. AWS tries to reconnect to the workspace, but it takes hours and eventually nothing happens.

Has anyone been in a situation like this? I work from Finland, maybe that is the reason?


#2

Hmm. Creating a C9 workspace worked seamlessly for me…and I have created several. I have noticed the workspace losing contact with the server on occasion. I can’t tell for sure if it is more frequently than the old Cloud 9. It is not frequent enough to be a problem.

You may try navigating to your Cloud 9 server via the EC2 dashboard. Maybe that dashboard can give you a clue as to why the Cloud 9 workspace is not working.

My main gripe with AWS EC2 is that they removed the file download feature. I wonder what other features they removed.


#3

Thanks a lot for your reply!

Almost breaking my head over this issue. I’ve tried different approaches, but nothing seems to be working in my case. AWS creates the workspace, no errors reported, which then hangs. AWS loses the connection to the workspace, saying that “it may be connected to VPC issues” when it tries to reconnect.

Creating VPC and subnet for the workspace doesn’t seem to be complicated and I follow the instruction carefully.
I don’t know. I’m very close close to give up on AWS. Just hoping old Cloud9 will be kept operational.

Thanks once again!


#4

In this environment an SSH environment or did you create an EC2 instance through Cloud 9?


#5

Through the Cloud9. As IAM user with Admin permissions and as a root user as well.