Apache2 Not Starting

apache

#1

I started up my C9 workspace today, and as usual, started the Apache2 server with the console command:

service apache2 start

The console gave the usual results:

* Starting web server apache2
*

Except if I remember correctly, there’s supposed to be a third asterisk. I tried to connect with my browser, but I got the ‘no workspace running’ screen. I tried to restart Apache2:

service apache2 restart

And the console outputted this:

* Restarting web server apache2
  ...fail!

I thought this to be quite strange, so I stopped the Apache2 in the terminal, and started a new Run command from the bar at the top of the screen: Run -> Run With -> Apache httpd (PHP, HTML).

Upon starting that Run command, I see the new terminal open at the bottom of the screen as usual, but then the button that says ‘Stop’ because the server is running changes to ‘Run’ because the server stopped, which took about 1 second to happen. No messages outputted to the terminal. It’s as if it died silently, with no reported errors. I am unable to start Apache2.

If anybody knows of what I may have done that’s broken this, or if this may be a C9-wide issue like last time? How can I fix this?


#2

I fixed the issue! I should have tried a workspace restart before bugging the C9 community about it! Just a simple workspace restart fixed the issue.


#3

A restart (closing the IDE window and reopening it) worked for me too, after I saw this error:

run-apache2: command not found

Just adding that in here in for anyone that googles for that specific error message.