Apache server after installing phpmyadmin shows 'index of'


#1

For the life of me I can’t figure this one out. After installing phpmyadmin, the apache server it creates has an index_of so if you go to the preview on c9users.io that everyone has my code is visible to everyone. This seems like a very bad default behavior by the way.

Security wise this is of course not good, so I disabled phpmyadmin immediately.

So far I tried removing indexes in /etc/apache2/apache2.conf to no avail.

Any help would be appreciated.


#2

Hey @Samuel_Westrich :smiley:,

Have you seen see this C9 Doc on setting up PHPMyAdmin:

and this blog post:


#3

yes but there’s no mention of how to disable apache index of.

see phpmyadmin runs on an apache server. and the default configuration clooud9 stuck with has apache index of turned on which leads to anyone being able to see my code while I use phpmyadmin.