Annoying visual glitch that prevents me from coding


#1

This is a very interesting visual glitch that I have encountered. While editing a file, signup.ejs, the file began glitching out, and causing seemingly random errors. The line numbers disappeared except for 1, and scrolling caused the insertion point and the line highlighter to mis-align to the the text on the page. It is the only file with this problem. I can edit the text, but the insertion point does not change, and sometimes inputs do weird things: I tried typing backspace, and it selected the character before the insertion point. Also, syntax highlighting stopped working on a single line (correct me if my syntax is wrong). I then refreshed the page and restarted the workspace several times, to no avail, but managed to receive different symptoms (different syntax highlighting problems, no I-beam). Below is a screenshot of the developer’s console.

There is no stacktrace below any of the errors. The line the state.indexOf error references is as follows:

This line --> for(var key in this.subModes)if(0===state.indexOf(key))return this.subModes[key] return null},this.$tryMode=function(state,session,foldStyle,row){var mode=this.$getMode(state) return mode?mode.getFoldWidget(session,foldStyle,row):""},this.getFoldWidget=function(session,foldStyle,row){ return this.$tryMode(session.getState(row-1),session,foldStyle,row)||this.$tryMode(session.getState(row),session,foldStyle,row)||this.defaultMode.getFoldWidget(session,foldStyle,row)
The line that the state.split error references is:

},this.$delegator=function(method,args,defaultHandler){var state=args[0] "string"!=typeof state&&(state=state[0]) This line --> for(var i=0;i<this.$embeds.length;i++)if(this.$modes[this.$embeds[i]]){var split=state.split(this.$embeds[i])

Congratulations on being acquired by Amazon, and keep up the amazing work!

EDIT: For some reason one of the images did not upload (bug), so I screenshotted it and reuploaded it.

EDIT (Again): Just in case you need it, my username is dannytech, the workspace in question is filmr-online, and the file is /home/ubuntu/workspace/views/public/pages/signup.ejs


#2

thanks for the detailed bug report, it helped us to track down and fix the issue.
The fix will be deployed to c9.io on monday.


#3

Being Tuesday, I tried to open the file and edit it, but the same problem is occurring with the same errors in the developer console. Is it possible that there is a problem with the file, and if so, can you try to fix it? Or has the solution not been deployed yet?


#4

Sorry, site deploy got delayed yesterday, the fix has been deployed just now


#5

I’m having the same problem, but it’s in all my files, I started using cloud9 today


#6

@Borreli then it is a different issue, please create a new topic, and add screenshot showing the issue.