An EXTREMELY annoying issue


#1

I can’t even begin to explain how stupid this bug is. So I was editing a JS file of mine, minding my own business, when I hit CTRL+A (and something else, I’m not sure what) and wiped my JS file of any code. No big deal, I can hit CTRL+Z, right? WRONG. It wouldn’t let me undo it. I figured “well shit, guess I’ll have to try Show File Revision history”. Now take note that this JS file (called definitions.js) is a large file with over 38k lines of code. When I clicked Show File Revision history, it just hung there. FOR 40 MINUTES IT HUNG. And when something finally happened, I get a crazy ass error saying I’ve used “367223/5120MB” of disk space (restarting brought the disk usage mostly back to normal). In short, the feature that’s supposed to fix mistakes like this failed at even doing that properly. And I have no other way to recover my file. So maybe a bit of help?! If I lose this file, it will be CATASTROPHIC on so many levels.


#2

It would help if I could actually get some FUCKING SUPPORT ON A SUPPORT FORUM. This one file is almost an entire damn year of work, and I’m not going to lose the thing because one of your core features couldn’t even do its job.


#3

Wow, nice to see that Cloud9’s support forums has been abandoned by Cloud9 themselves. It never had to be like this, AWS Cloud9 shouldn’t have happened, Cloud9 should’ve just stayed Cloud9. Anyways, I let the workspace sit for 3 hours and I was finally able to access the File Revision History thing. Issue is solved, not like any of the support team will care though.


#4

Hello, I cannot offer any help, unfortunately. Only commiserate.
But your issue and lack of response from AWS is a travesty to behold.
You are right, of course, C9 should never have sold out.
I DO wish you luck in resolving your issue.


#5

About that…already solved. But glad to see I’m not alone on my opinion about AWS.


#6

Who would response to this kind of statement. If you are writing 38k lines of code for a year, just back it up. I assume git would the job…