Access to Organization Repositories

github

#1

I have linked my GitHub account to the Cloud9 one. Tried to create a new workspace by linking the organization’s repositories. Unfortunately, although no error shows, I am not able to see the repository and its tree.
I tried then to download the repository to GitHub desktop -which was successful-, but then when I tried to see all my GitHub repositories in my Cloud9 account, it was not showing.

Can someone shed some light as to how you open a code repository from GitHub organization I am linked to?


#2

Assuming I understand correctly, this is the solution:

  • Go to https://github.com/settings/applications, and click on Cloud9 (the link, DO NOT click Revoke):
  • You should see a list of organizations you are a part of at the bottom. You can manually allow access there, but with organizations that you do not have Owner access to, you’ll need to request access from an Owner.
  • Then, on the Cloud9 repositories page, you should see all repositories from the organizations you authorized (these may take some time to load, depending on the amount of repositories).