A strange Mongodb crash without a mongo.lock?

mongodb

#1

Hi,

I didn’t close Mongo and it seemed to have crashed. I’m getting the error code “events.js:160”
(see print screens below), but going through the solutions so far I’ve tried to repair mongo, to kill all processes from the pop up window at the terminal and also as a command (kill -9 $(lsof -i:$PORT -t)), I’ve tried deleting the Mongo.lock (though I couldn’t find it at first) but nothing works.

The strange thing is that the DB is currently online for the app I was working on when it crashed - I was able to upload data to it and it stayed there after restarting the server (Also - I can restart the server on that app without any trouble - print screens below).

So… I can’t use any other app right now, at least not with a DB, but I can’t shut down the process either. It’s stuck on that one app and that may be the reason why I can’t find the mongo.lock anywhere - because it is not exactly locked, but actually online…

These 3 print screens were taken at the same time:

The error code when trying the new app -

The operational mongod -
[as a new user I can apparently only load one picture per post. The terminal seems to have added another line at the end. These are the last two lines:
[initandlisten] waiting for connections on port 27017
[websvr] admin web console waiting for connections on port 28017
]

The operational app where it seemed to have crashed -
[as a new user I can apparently only load one picture per post. The terminal looks normal here. Server is online]

Any help or insight will be very much appreciated.
Thanks! :slight_smile: