A Ramdisk to test with?


#1

Just out of curiosity, would it be possible to setup a ramdisk for testing purposes?


#2

What software will you be using for the ramdisk? As long as it can run on Ubuntu inside a docker container it should be possible.


#3

Nothing at the moment but when I tried to do a simple tmpfs mount, it’d fail to do it. I’d get a permission denied error even with sudo. I thought maybe it could be used for an application cache or something.

The only ramdisk I can access is the 64MB one mounted to /dev/shm.

I tried;
sudo mount -t tmpfs -o size=512M,mode=0775 tmpfs tmp


#4

There is also no loop devices for mounting images or a ramdisk.


#5

In order to be able to mount filesystems from within a docker container you would essentially need --privileged option turned on. Which is tantamount to giving root access to the host, this is because mount requires the CAP_SYS_ADMIN flag to be set, which also unlocks a lot of other admin-only features within the container. So mounting additional filesystems is not currently supported on our platform, sorry.


#6

Fair enough. It was a thought.