502 Bad Gateway error

workspace

#1

When trying to access my page: https://sandbox-richwagner68.c9users.io

Getting an html response:

Error 502 - Bad Gateway .error_content { background: rgba(255, 255, 255, 0.23); padding: 10px; width: 641px; margin: 25px 0; display: none; }
#error-msg {
    display: block;
}
</style>

Error 502 - Bad Gateway

Please click here to try again, if the issue persists please contact support

  <a href="http://status.c9.io">Status Page</a> |
  <a href="https://c9.io/support">Support</a> |
  <a href="https://c9.io/dashboard.html">Dashboard</a> |
  <a href="https://c9.io">Home</a>
</div>

502 Bad Gateway Error w/ NPM and Angular2
#2

We’re currently looking into this issue and will post updates here as we have them. Thank you for the report!


#3

##Angular2 and NPM

  • Double Checked Angular
    1. Components
    2. Directives
    3. Selectors
    4. Import statements
    5. Etc.

The first page doesn’t even load… Does anyone have any ideas on troubleshooting?


#4

Any result or information? I’m on a deadline and staring at a 502 error instead of my paid dev site.

In the past days I could hit refresh a bunch of times. A QA person hit the same and I told her to refresh a few times, but now it seems to be dead.


#5

Can you provide some details such as which server application you are using (Apache, NodeJS, etc) and the workspace?


#6

Apache, standard “Apache httpd (PHP, HTML)” runner (the problem occurs with and without XDebug turned on). PHP project pulled from GitHub, no changes to the config other than pointing all requests at a router entry script. Very standard setup, in part because this was a workspace designed for our documentation on getting a dev installation up and running on Cloud9.

After a number of refreshes, it usually “finds” the site and works for awhile.

I had realized this was a semi-old thread, and thus possibly unrelated to my issue, so I also opened a new thread. Sorry for the duplicate; I could not decide which was the right way to go (opening a new topic or replying to this one).

Workspace changes

The one change to Apache was to edit /etc/apache2/sites-enabled/001-cloud9.conf and add the following (in the appropriate place, this is from the notes I took as I made the changes):

    Alias / /home/ubuntu/sites/dev.php/

</VirtualHost>

<Directory /home/ubuntu/sites>
  Require all granted
  Allow from all
</Directory>

Also, two packages were added with:

sudo apt update
sudo apt install php5-imagick ffmpegthumbnailer

Finally, a MySQL user and database were created.